记录锦鲤log版global-agent依赖安装

第二次写了,废话还是有点多,各位大佬将就着看,只是一个慢慢摸爬滚打的小菜qio罢了

只是记录一下自己遇到这个问题希望能帮助同样问题的人罢了,毕竟折腾了挺久的,

轻喷

今天没有什么图,因为我已经安装好了,进入容器终端

npm install global-agent

之后显示这个

百度翻译了一下大概就是要我修复树,然后运行代码

npm install --force

npm install --legacy-peer-deps #两者二选一

虽然不知道什么意思但是大概就是说失败了呗,猜测可能是版本问题,于是升级

npm i -g [email protected]
#升级到指定版本
npm install -g npm#或者
npm i -g latest
#升级到最新版本
npm i -g stable
#升级到最稳定版本
npm -v
#查看版本

一套下来,重新安装global-agent。

人直接麻了,直接复制粘贴查,需要出国(有些东西确实科学上网才能查到)

看了一下大致意思是需要6.0+版本的npm,我是8.4.1版本的npm,所以我的版本不是低了反而超前了?查询网上的资料后得到一个命令

npx -p [email protected] npm install --legacy-peer-deps
#还是修复树

第一次没成功再来一次就成功了成功之后,重新用低版本npm安装global-agent

npx -p [email protected] npm install global-agent

安装之后,有报错

read-shrinkwrap This version of npm is compatible with [email protected], 
but package-lock.json was generated for [email protected] I'll try to do my best with it!

英语差的我看到这个报错差点直接暴走,还好有百度翻译(励志要学好英语)

返回之后就可以直接跑了

资料参考:

贴一个大佬的频道,不知道会不会违规,先隐藏了

-> 加入科技玩家交流群组:点击加入 <-
注意:
1.文中二维码和链接可能带有邀请性质,请各位玩家自行抉择。
2.请勿通过链接填写qq号与密码、银行卡号与密码等个人隐私信息。
3.禁止纯拉人头,拉app注册等信息,发现必小黑屋。
4.同一种信息仅发一次,多发会被删除。
5.文章中源码或APP等,无法保证其绝对安全,需自行辨别。
6.文章关联方不想展示也可以微信站长“socutesheep”删除。
本文由 @斡嵇 发布。如若转载,请注明出处: 科技玩家 » 记录锦鲤log版global-agent依赖安装

给TA买糖
共{{data.count}}人
人已买糖
教程玩家投稿

python 实现 ssh 客户端远控

2022-5-7 13:38:11

教程玩家投稿精选文章

内网搭建 pip 源方案之 pypiserver

2022-5-9 1:52:32

271 条回复 A文章作者 M管理员
贴心提醒
请认真对待作者付出,勿发表无意义言论,触发过滤规则的评论将无法提交,包含敏感词的评论会自动变成待审核状态哦。
  1. 小虎

    学习学习

  2. zerooo

    感谢分享

  3.  26112

    学习学习

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索