部分安装青龙加了代理就无法安装依赖解决办法

当你安装青龙docker加了代理时安装依赖就会提示这个,
ERROR: Could not install packages due to an Environment
Error: Missing dependencies for SOCKS support.

因为本机设置了sock5代理,但pip需要Pysocks依赖 才可以走sock5代理

解决方法就是要先Pysocks依赖,但是又不能在线安装,只能下载下来离线安装

具体方法就是下载文件解压到容器里面

cd PySocks-1.7.1

python setup.py install

随后就能正常安装依赖了

https://www.cnpython.com/pypi/pysocks/dl-PySocks-1.7.1.tar.gz

-> 加入科技玩家交流群组:点击加入 注意:
1.文中二维码和链接可能带有邀请性质,请各位玩家自行抉择。
2.请勿通过链接填写qq号与密码、银行卡号与密码等个人隐私信息。
3.禁止纯拉人头,拉app注册等信息,发现必小黑屋。
4.同一种信息仅发一次,多发会被删除。
5.文章中源码或APP等,无法保证其绝对安全,需自行辨别。
6.文章关联方不想展示也可以微信站长“socutesheep”删除。
本文由 @kk 发布。如若转载,请注明出处: 科技玩家 » 部分安装青龙加了代理就无法安装依赖解决办法

给TA买糖
共{{data.count}}人
人已买糖
教程玩家投稿

为你的linux服务器添加ssh登陆提醒

2022-12-28 21:07:52

教程玩家投稿

超牛CKTool工具轻松抓gold东wskey

2023-1-23 18:56:19

6 条回复 A文章作者 M管理员
贴心提醒
请认真对待作者付出,勿发表无意义言论,触发过滤规则的评论将无法提交,包含敏感词的评论会自动变成待审核状态哦。
  1. 亦云

    打卡升级

  2. 0o壞尛孒o0

    打卡升级

  3. 哈喽哈哈

    打卡升级

  4. ALen2022

    打卡升级

  5. wik6

    👍点个赞.

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索